Minergate Forum

Forum of the best Mining Pool ever.

2017 MacBook Pro - Radeon Pro 560 4GB of GDDR5

Moderators: ikanunaki, Janika, Zhe, Ar1k88, Dossis, DanteSama, tykari

jmfronsee
Posts: 4
Joined: Tue Aug 01, 2017 9:17 am

2017 MacBook Pro - Radeon Pro 560 4GB of GDDR5

Postby jmfronsee » Tue Aug 01, 2017 10:14 am

I know, I should not be mining with a MAC. But I am a programmer/nerd and at this point I just want to get it to work, for principle. And to occasionally let it mine for a few hours here and there. I posted most of this in the "Having GPU Trouble? Tell us the model!" ( viewtopic.php?f=15&t=2429 ), thread just so Minergate has the model & a few details (admins, feel free to strip my other comment down to just the name of my GPUs, we can keep this the master information thread). I figure others running into Macbook Pro Ether mining issues, or any Mac with "Graphics switching" might want to discuss. And it relates to other miners not just Minergate.

1) Macbook Pro 2017. Radeon Pro 560 with 4GB of GDDR5 memory, dedicated GPU. It also has an integrated Intel GPU + graphics switching.
I have yet to get this Radeon Pro 560 GPU to mine with ANY software (and "unavailable" in MinerGate GUI). My guess is that the built in graphics switching messes something up. I got close with ETHminer. I can get it to list both devices / GPUs. But cannot get it to mine ETH with the Pro 560. For some crazy reason it WILL mine with the integrated version, which doesnt make sense because it doesnt have 4GB of RAM (or 3GB, whatever the DAG is now). It must be using shared memory or something, borrowing from system RAM to build the DAG. As it only mines at about 1.5 - 2 MH/s of ETH. There is an article on Steemit, How to mine ETH with GPU on your Mac by soon8013 saying he got his Radeon Pro 560 to mine ETH on a MacBook Pro. Not sure if I am allowed to post links, but this should be read by anyone interested:
https://steemit.com/mining/@soon8013/ho ... n-your-mac

Unfortunately he is mistaken. His setup is doing the same error/glitch as mine. He is only mining using the integrated GPU. he gets the same 1.57 MH/s, the Pro 560 should be getting quite a bit higher than that. I would comment there as well, but Steemit has yet to approve my account... soon8013 if you read this, keep an eye on your terminal when execute ethminer, you will see even when you think you are selecting the dedicated GPU, the console tells you you are actually starting mining with the intel integrated, hence your low hashrate! I wish he would have posted the command output from the start of executing Ethminer.

Ethminer has some glitch in it... --list-devices DOES show both of my GPUs. But not matter what I specify for --opencl-device it starts mining with integrated intel, and the command output confirms this. I also tried specifying opencl-platform 1, but it then tells me that no GPU capable of mining was found, or something along that line.

Anyone find a solution to this?

* Quick sidenote, on my HP Pavilion laptop. Also with an INTEL integrated + dedicated GPU setup ( NVIDIA GeForce GTX 960M 2GB GDDR5 ). Benchmark in Minergate GUI crashes. And mining with GPU on altcoins is not returning a 2GB GPU worthy hashrate... Why can we not specify via drop down what GPU we want to mine with? I need to play around with some command line miners on this machine as well to see if same graphics switching issue is happening, but on a Windows OS.

Whelp... See ya later!

jmfronsee
Posts: 4
Joined: Tue Aug 01, 2017 9:17 am

Re: 2017 MacBook Pro - Radeon Pro 560 4GB of GDDR5

Postby jmfronsee » Wed Aug 09, 2017 11:51 pm

Hey-o, here goes a big ol' bump! I would much rather just use the Minergate GUI - why does this powerful 4GB GUI "not allowed" and GPU mining is disabled when I run on this MacBook? Now ill get some replies I bet... No replies to support email requests either. *Sigh*


Return to “English Forum”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests